#326987 success

Fixes #4

fa9a25aNicolas Stalder

Owner
~nickray
Created
2 months ago
Updated
2 months ago
Build manifest
view manifest »

Tasks

view log »
setup view log »
build-tweetnacl view log »
build-haase view log »
test view log »
go to bottom »
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
[#326987] 2020/10/24 22:36:06 Booting image freebsd/latest (default) on port 22874
[#326987] 2020/10/24 22:36:07 Waiting for guest to settle
[#326987] 2020/10/24 22:36:28 Sending tasks
[#326987] 2020/10/24 22:36:29 Sending build environment
[#326987] 2020/10/24 22:36:29 Installing packages
Warning: Permanently added '[localhost]:22874' (ECDSA) to the list of known hosts.
Updating FreeBSD repository catalogue...
Fetching meta.txz: . done
Fetching packagesite.txz: .......... done
Processing entries: .......... done
FreeBSD repository update completed. 31854 packages processed.
All repositories are up to date.
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
New version of pkg detected; it needs to be installed first.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
	pkg: 1.14.6 -> 1.15.10

Number of packages to be upgraded: 1

7 MiB to be downloaded.
[1/1] Fetching pkg-1.15.10.txz: .......... done
Checking integrity... done (0 conflicting)
[1/1] Upgrading pkg from 1.14.6 to 1.15.10...
[1/1] Extracting pkg-1.15.10: .......... done
pkg: Failed to execute lua script: [string "args = {}..."]:11: attempt to call a nil value (field 'stat')
pkg: lua script failed
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (31 candidates): .......... done
Processing candidates (31 candidates): .......... done
The following 45 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
	bash-completion: 2.11,2
	glib: 2.66.1_1,1
	libedit: 3.1.20191231,1
	libiconv: 1.16
	libxml2: 2.9.10_1
	p5-Clone: 0.45
	p5-Encode-Locale: 1.05
	p5-HTTP-Date: 6.05
	p5-HTTP-Message: 6.26
	p5-IO-HTML: 1.001_1
	p5-LWP-MediaTypes: 6.04
	p5-TimeDate: 2.33,1
	p5-URI: 1.76
	py37-setuptools: 44.0.0

Installed packages to be UPGRADED:
	bash: 5.0.17 -> 5.0.18_3
	ca_root_nss: 3.54 -> 3.58
	curl: 7.71.1 -> 7.73.0
	gettext-runtime: 0.20.2 -> 0.21
	git: 2.27.0 -> 2.28.0
	gnupg: 2.2.21 -> 2.2.23
	gnutls: 3.6.14 -> 3.6.15
	libffi: 3.3 -> 3.3_1
	libgcrypt: 1.8.5 -> 1.8.6
	libgpg-error: 1.38 -> 1.39
	mercurial: 5.1.2 -> 5.5_1
	p11-kit: 0.23.20_1 -> 0.23.21
	p5-CGI: 4.50 -> 4.51
	p5-HTML-Parser: 3.72 -> 3.75
	p5-Mozilla-CA: 20180117 -> 20200520
	perl5: 5.30.3 -> 5.32.0
	python37: 3.7.8_1 -> 3.7.9_1
	sqlite3: 3.32.3,1 -> 3.33.0,1
	sudo: 1.9.1 -> 1.9.3p1
	trousers: 0.3.14_2 -> 0.3.14_3

Installed packages to be REINSTALLED:
	p5-Authen-SASL-2.16_1 (direct dependency changed: perl5)
	p5-Digest-HMAC-1.03_1 (direct dependency changed: perl5)
	p5-Error-0.17029 (direct dependency changed: perl5)
	p5-GSSAPI-0.28_1 (direct dependency changed: perl5)
	p5-HTML-Tagset-3.20_1 (direct dependency changed: perl5)
	p5-IO-Socket-INET6-2.72_1 (direct dependency changed: perl5)
	p5-IO-Socket-SSL-2.068 (direct dependency changed: perl5)
	p5-Net-SSLeay-1.88 (direct dependency changed: perl5)
	p5-Socket6-0.29 (direct dependency changed: perl5)
	p5-Term-ReadKey-2.38_1 (direct dependency changed: perl5)
	p5-subversion-1.14.0 (direct dependency changed: perl5)

Number of packages to be installed: 14
Number of packages to be upgraded: 20
Number of packages to be reinstalled: 11

The process will require 36 MiB more space.
60 MiB to be downloaded.
[1/45] Fetching trousers-0.3.14_3.txz: .......... done
[2/45] Fetching sudo-1.9.3p1.txz: .......... done
[3/45] Fetching sqlite3-3.33.0,1.txz: .......... done
[4/45] Fetching python37-3.7.9_1.txz: .......... done
[5/45] Fetching perl5-5.32.0.txz: .......... done
[6/45] Fetching p5-subversion-1.14.0.txz: .......... done
[7/45] Fetching p5-Term-ReadKey-2.38_1.txz: ... done
[8/45] Fetching p5-Socket6-0.29.txz: ... done
[9/45] Fetching p5-Net-SSLeay-1.88.txz: .......... done
[10/45] Fetching p5-Mozilla-CA-20200520.txz: .......... done
[11/45] Fetching p5-IO-Socket-SSL-2.068.txz: .......... done
[12/45] Fetching p5-IO-Socket-INET6-2.72_1.txz: .. done
[13/45] Fetching p5-HTML-Tagset-3.20_1.txz: .. done
[14/45] Fetching p5-HTML-Parser-3.75.txz: .......... done
[15/45] Fetching p5-GSSAPI-0.28_1.txz: ...... done
[16/45] Fetching p5-Error-0.17029.txz: .... done
[17/45] Fetching p5-Digest-HMAC-1.03_1.txz: .. done
[18/45] Fetching p5-CGI-4.51.txz: .......... done
[19/45] Fetching p5-Authen-SASL-2.16_1.txz: ...... done
[20/45] Fetching p11-kit-0.23.21.txz: .......... done
[21/45] Fetching mercurial-5.5_1.txz: .......... done
[22/45] Fetching libgpg-error-1.39.txz: .......... done
[23/45] Fetching libgcrypt-1.8.6.txz: .......... done
[24/45] Fetching libffi-3.3_1.txz: ..... done
[25/45] Fetching gnutls-3.6.15.txz: .......... done
[26/45] Fetching gnupg-2.2.23.txz: .......... done
[27/45] Fetching git-2.28.0.txz: .......... done
[28/45] Fetching gettext-runtime-0.21.txz: .......... done
[29/45] Fetching curl-7.73.0.txz: .......... done
[30/45] Fetching ca_root_nss-3.58.txz: .......... done
[31/45] Fetching bash-5.0.18_3.txz: .......... done
[32/45] Fetching libedit-3.1.20191231,1.txz: .......... done
[33/45] Fetching p5-HTTP-Message-6.26.txz: .......... done
[34/45] Fetching p5-LWP-MediaTypes-6.04.txz: ... done
[35/45] Fetching p5-HTTP-Date-6.05.txz: .. done
[36/45] Fetching p5-TimeDate-2.33,1.txz: ..... done
[37/45] Fetching p5-URI-1.76.txz: .......... done
[38/45] Fetching p5-IO-HTML-1.001_1.txz: .. done
[39/45] Fetching p5-Clone-0.45.txz: .. done
[40/45] Fetching p5-Encode-Locale-1.05.txz: .. done
[41/45] Fetching bash-completion-2.11,2.txz: .......... done
[42/45] Fetching glib-2.66.1_1,1.txz: .......... done
[43/45] Fetching libxml2-2.9.10_1.txz: .......... done
[44/45] Fetching libiconv-1.16.txz: .......... done
[45/45] Fetching py37-setuptools-44.0.0.txz: .......... done
Checking integrity... done (0 conflicting)
[1/45] Upgrading libffi from 3.3 to 3.3_1...
[1/45] Extracting libffi-3.3_1: .......... done
[2/45] Upgrading gettext-runtime from 0.20.2 to 0.21...
[2/45] Extracting gettext-runtime-0.21: .......... done
[3/45] Upgrading python37 from 3.7.8_1 to 3.7.9_1...
[3/45] Extracting python37-3.7.9_1: .......... done
[4/45] Upgrading libgpg-error from 1.38 to 1.39...
[4/45] Extracting libgpg-error-1.39: .......... done
[5/45] Upgrading bash from 5.0.17 to 5.0.18_3...
[5/45] Extracting bash-5.0.18_3: .......... done
[6/45] Installing libxml2-2.9.10_1...
[6/45] Extracting libxml2-2.9.10_1: .......... done
[7/45] Installing libiconv-1.16...
[7/45] Extracting libiconv-1.16: .......... done
[8/45] Upgrading perl5 from 5.30.3 to 5.32.0...
[8/45] Extracting perl5-5.32.0: .......... done
[9/45] Upgrading ca_root_nss from 3.54 to 3.58...
[9/45] Extracting ca_root_nss-3.58: ........ done
[10/45] Installing bash-completion-2.11,2...
[10/45] Extracting bash-completion-2.11,2: .......... done
[11/45] Installing glib-2.66.1_1,1...
[11/45] Extracting glib-2.66.1_1,1: .......... done
No schema files found: doing nothing.
[12/45] Upgrading trousers from 0.3.14_2 to 0.3.14_3...
===> Creating groups.
Using existing group '_tss'.
===> Creating users
Using existing user '_tss'.
[12/45] Extracting trousers-0.3.14_3: .......... done
[13/45] Upgrading p11-kit from 0.23.20_1 to 0.23.21...
[13/45] Extracting p11-kit-0.23.21: .......... done
[14/45] Installing libedit-3.1.20191231,1...
[14/45] Extracting libedit-3.1.20191231,1: .......... done
[15/45] Installing p5-TimeDate-2.33,1...
[15/45] Extracting p5-TimeDate-2.33,1: .......... done
[16/45] Upgrading sqlite3 from 3.32.3,1 to 3.33.0,1...
[16/45] Extracting sqlite3-3.33.0,1: .......... done
[17/45] Upgrading libgcrypt from 1.8.5 to 1.8.6...
[17/45] Extracting libgcrypt-1.8.6: .......... done
[18/45] Upgrading gnutls from 3.6.14 to 3.6.15...
[18/45] Extracting gnutls-3.6.15: .......... done
[19/45] Installing p5-LWP-MediaTypes-6.04...
[19/45] Extracting p5-LWP-MediaTypes-6.04: ........ done
[20/45] Installing p5-HTTP-Date-6.05...
[20/45] Extracting p5-HTTP-Date-6.05: ....... done
[21/45] Installing p5-URI-1.76...
[21/45] Extracting p5-URI-1.76: .......... done
[22/45] Installing p5-IO-HTML-1.001_1...
[22/45] Extracting p5-IO-HTML-1.001_1: ....... done
[23/45] Installing p5-Clone-0.45...
[23/45] Extracting p5-Clone-0.45: ......... done
[24/45] Installing p5-Encode-Locale-1.05...
[24/45] Extracting p5-Encode-Locale-1.05: ....... done
[25/45] Reinstalling p5-Socket6-0.29...
[25/45] Extracting p5-Socket6-0.29: ....... done
[26/45] Reinstalling p5-HTML-Tagset-3.20_1...
[26/45] Extracting p5-HTML-Tagset-3.20_1: ....... done
[27/45] Upgrading gnupg from 2.2.21 to 2.2.23...
[27/45] Extracting gnupg-2.2.23: .......... done
[28/45] Installing p5-HTTP-Message-6.26...
[28/45] Extracting p5-HTTP-Message-6.26: .......... done
[29/45] Reinstalling p5-Net-SSLeay-1.88...
[29/45] Extracting p5-Net-SSLeay-1.88: .......... done
[30/45] Upgrading p5-Mozilla-CA from 20180117 to 20200520...
[30/45] Extracting p5-Mozilla-CA-20200520: ........ done
[31/45] Reinstalling p5-IO-Socket-INET6-2.72_1...
[31/45] Extracting p5-IO-Socket-INET6-2.72_1: ....... done
[32/45] Upgrading p5-HTML-Parser from 3.72 to 3.75...
[32/45] Extracting p5-HTML-Parser-3.75: .......... done
[33/45] Reinstalling p5-GSSAPI-0.28_1...
[33/45] Extracting p5-GSSAPI-0.28_1: .......... done
[34/45] Reinstalling p5-Digest-HMAC-1.03_1...
[34/45] Extracting p5-Digest-HMAC-1.03_1: .......... done
[35/45] Reinstalling p5-subversion-1.14.0...
[35/45] Extracting p5-subversion-1.14.0: .......... done
[36/45] Reinstalling p5-Term-ReadKey-2.38_1...
[36/45] Extracting p5-Term-ReadKey-2.38_1: ........ done
[37/45] Reinstalling p5-IO-Socket-SSL-2.068...
[37/45] Extracting p5-IO-Socket-SSL-2.068: .......... done
[38/45] Reinstalling p5-Error-0.17029...
[38/45] Extracting p5-Error-0.17029: ......... done
[39/45] Upgrading p5-CGI from 4.50 to 4.51...
[39/45] Extracting p5-CGI-4.51: .......... done
[40/45] Reinstalling p5-Authen-SASL-2.16_1...
[40/45] Extracting p5-Authen-SASL-2.16_1: .......... done
[41/45] Upgrading curl from 7.71.1 to 7.73.0...
[41/45] Extracting curl-7.73.0: .......... done
[42/45] Installing py37-setuptools-44.0.0...
[42/45] Extracting py37-setuptools-44.0.0: .......... done
[43/45] Upgrading sudo from 1.9.1 to 1.9.3p1...
[43/45] Extracting sudo-1.9.3p1: .......... done
You may need to manually remove /usr/local/etc/sudoers if it is no longer needed.
[44/45] Upgrading mercurial from 5.1.2 to 5.5_1...
[44/45] Extracting mercurial-5.5_1: .......... done
[45/45] Upgrading git from 2.27.0 to 2.28.0...
===> Creating groups.
Using existing group 'git_daemon'.
===> Creating users
Using existing user 'git_daemon'.
[45/45] Extracting git-2.28.0: .......... done
=====
Message from bash-completion-2.11,2:

--
To enable the bash completion library, add the following to
your .bashrc file:

[[ $PS1 && -f /usr/local/share/bash-completion/bash_completion.sh ]] && \
	source /usr/local/share/bash-completion/bash_completion.sh

See /usr/local/share/doc/bash-completion/README.md for more information.
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 4 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
	arm-none-eabi-binutils: 2.33.1_3,1
	arm-none-eabi-gcc: 8.4.0_2
	mpc: 1.1.0_2
	mpfr: 4.1.0

Number of packages to be installed: 4

The process will require 148 MiB more space.
23 MiB to be downloaded.
[1/4] Fetching arm-none-eabi-gcc-8.4.0_2.txz: .......... done
[2/4] Fetching mpfr-4.1.0.txz: .......... done
[3/4] Fetching mpc-1.1.0_2.txz: .......... done
[4/4] Fetching arm-none-eabi-binutils-2.33.1_3,1.txz: .......... done
Checking integrity... done (0 conflicting)
[1/4] Installing mpfr-4.1.0...
[1/4] Extracting mpfr-4.1.0: .......... done
[2/4] Installing mpc-1.1.0_2...
[2/4] Extracting mpc-1.1.0_2: ......... done
[3/4] Installing arm-none-eabi-binutils-2.33.1_3,1...
[3/4] Extracting arm-none-eabi-binutils-2.33.1_3,1: .......... done
[4/4] Installing arm-none-eabi-gcc-8.4.0_2...
[4/4] Extracting arm-none-eabi-gcc-8.4.0_2: .......... done
=====
Message from arm-none-eabi-binutils-2.33.1_3,1:

--
===>   NOTICE:

The arm-none-eabi-binutils port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
[#326987] 2020/10/24 22:39:23 Cloning repositories
Cloning into 'salty'...
+ cd salty
+ git checkout -q fa9a25a20c28804f34ed2357297c41fecededb13
+ cd salty
+ git submodule update --init
Submodule 'c-api/libopencm3' (https://github.com/libopencm3/libopencm3) registered for path 'c-api/libopencm3'
Cloning into '/usr/home/build/salty/c-api/libopencm3'...
Submodule path 'c-api/libopencm3': checked out '08c5f2a1fb16b279907eb622ac043046d7a1a35c'
[#326987] 2020/10/24 22:39:33 Running task setup
[#326987] 2020/10/24 22:40:00 Running task build-tweetnacl
[#326987] 2020/10/24 22:40:54 Running task build-haase
[#326987] 2020/10/24 22:40:56 Running task test
[#326987] 2020/10/24 22:41:03 Processing post-success triggers...
[#326987] 2020/10/24 22:41:04 Sending webhook...
[#326987] 2020/10/24 22:41:04 Webhook response: 200
[#326987] 2020/10/24 22:41:04 Error updating GitHub status
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
+ curl -sSf https://sh.rustup.rs
+ sh -s -- -y -q
info: downloading installer
Warning: Not enforcing strong cipher suites for TLS, this is potentially less secure
Warning: Not enforcing TLS v1.2, this is potentially less secure
info: profile set to 'default'
info: default host triple is x86_64-unknown-freebsd
info: syncing channel updates for 'stable-x86_64-unknown-freebsd'
info: latest update on 2020-10-08, rust version 1.47.0 (18bf6b4f0 2020-10-07)
info: downloading component 'cargo'
info: downloading component 'clippy'
info: downloading component 'rust-std'
info: downloading component 'rustc'
info: downloading component 'rustfmt'
info: installing component 'cargo'
info: Defaulting to 500.0 MiB unpack ram
info: installing component 'clippy'
info: installing component 'rust-std'
info: installing component 'rustc'
info: installing component 'rustfmt'
info: default toolchain set to 'stable'

  stable installed - rustc 1.47.0 (18bf6b4f0 2020-10-07)


Rust is installed now. Great!

To get started you need Cargo's bin directory ($HOME/.cargo/bin) in your PATH
environment variable. Next time you log in this will be done
automatically.

To configure your current shell run source $HOME/.cargo/env
+ source /home/build/.cargo/env
++ export PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
++ PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
+ rustup target add thumbv7em-none-eabi
info: downloading component 'rust-std' for 'thumbv7em-none-eabi'
info: installing component 'rust-std' for 'thumbv7em-none-eabi'
info: Defaulting to 500.0 MiB unpack ram
build-tweetnacl
1
2
3
4
5
6
7
8
9
10
11
12
+ cd salty
+ source /home/build/.cargo/env
++ export PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
++ PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
+ RUSTFLAGS='-D warnings'
+ cargo build --release --features tweetnacl-on-cortex-m4 --target thumbv7em-none-eabi
    Updating crates.io index
 Downloading crates ...
  Downloaded subtle v2.3.0
   Compiling salty v0.1.0-alpha.1 (/usr/home/build/salty)
   Compiling subtle v2.3.0
    Finished release [optimized] target(s) in 53.25s
build-haase
1
2
3
4
5
6
7
8
+ cd salty
+ source /home/build/.cargo/env
++ export PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
++ PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
+ RUSTFLAGS='-D warnings'
+ cargo build --release --target thumbv7em-none-eabi
   Compiling salty v0.1.0-alpha.1 (/usr/home/build/salty)
    Finished release [optimized] target(s) in 1.72s
test
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
+ cd salty
+ source /home/build/.cargo/env
++ export PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
++ PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
+ cargo test --release
 Downloading crates ...
  Downloaded proc-macro-hack v0.5.18
  Downloaded hex-literal-impl v0.2.2
  Downloaded hex-literal v0.2.1
   Compiling proc-macro-hack v0.5.18
   Compiling subtle v2.3.0
   Compiling salty v0.1.0-alpha.1 (/usr/home/build/salty)
   Compiling hex-literal-impl v0.2.2
   Compiling hex-literal v0.2.1
    Finished release [optimized] target(s) in 5.19s
     Running target/release/deps/salty-c31aa84e040c670b

running 22 tests
test curve::tests::test_negation ... ok
test curve::tests::test_addition_vs_multiplication ... ok
test curve::tests::test_some_more ... ok
test curve::tests::test_neutral_is_neutral ... ok
test field::tweetnacl::tests::test_imaginary ... ok
test field::tweetnacl::tests::test_inversion ... ok
test field::tweetnacl::tests::test_negation ... ok
test field::tweetnacl::tests::test_one_times_zero ... ok
test field::tweetnacl::tests::test_one_plus_one ... ok
test field::tweetnacl::tests::test_two_times_three_is_six ... ok
test field::tweetnacl::tests::test_square_roots ... ok
test scalar29::test::add ... ok
test scalar29::test::from_bytes_wide ... ok
test scalar29::test::montgomery_mul ... ok
test scalar29::test::montgomery_mul_max ... ok
test scalar29::test::mul_max ... ok
test scalar29::test::mul ... ok
test scalar29::test::sub ... ok
test signature::tests::test_ed25519ph_with_rfc_8032_test_vector ... ok
test signature::tests::test_reduction_of_s_modulo_ell ... ok
test signature::tests::test_signature ... ok
test signature::tests::test_decompression ... ok

test result: ok. 22 passed; 0 failed; 0 ignored; 0 measured; 0 filtered out

   Doc-tests salty

running 5 tests
test src/lib.rs - (line 35) ... ok
test src/lib.rs - (line 27) ... ok
test src/lib.rs - (line 44) ... ok
test src/lib.rs - (line 57) ... ok
test src/lib.rs - (line 70) ... ok

test result: ok. 5 passed; 0 failed; 0 ignored; 0 measured; 0 filtered out

Build complete: success 2 months ago (took 4 minutes)