#311310 failed

Temporary commit for testing

fb96309Nicolas Stalder

Owner
~nickray
Created
3 months ago
Updated
3 months ago
Build manifest
view manifest »

Tasks

view log »
setup view log »
build-tweetnacl view log »
build-haase view log »
test view log »
go to bottom »
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
[#311310] 2020/09/29 21:32:32 Booting image freebsd/latest (default) on port 22220
[#311310] 2020/09/29 21:32:34 Waiting for guest to settle
[#311310] 2020/09/29 21:32:55 Sending tasks
[#311310] 2020/09/29 21:32:56 Sending build environment
[#311310] 2020/09/29 21:32:56 Installing packages
Warning: Permanently added '[localhost]:22220' (ECDSA) to the list of known hosts.
Updating FreeBSD repository catalogue...
Fetching meta.txz: . done
Fetching packagesite.txz: .......... done
Processing entries: .......... done
FreeBSD repository update completed. 31874 packages processed.
All repositories are up to date.
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
New version of pkg detected; it needs to be installed first.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
	pkg: 1.14.6 -> 1.15.6

Number of packages to be upgraded: 1

7 MiB to be downloaded.
[1/1] Fetching pkg-1.15.6.txz: .......... done
Checking integrity... done (0 conflicting)
[1/1] Upgrading pkg from 1.14.6 to 1.15.6...
[1/1] Extracting pkg-1.15.6: .......... done
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (30 candidates): .......... done
Processing candidates (30 candidates): .......... done
The following 36 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
	bash-completion: 2.11,2
	glib: 2.66.0_1,1
	libedit: 3.1.20191231,1
	libiconv: 1.16
	libxml2: 2.9.10
	py37-setuptools: 44.0.0

Installed packages to be UPGRADED:
	bash: 5.0.17 -> 5.0.18_3
	ca_root_nss: 3.54 -> 3.57
	curl: 7.71.1 -> 7.72.0
	gettext-runtime: 0.20.2 -> 0.21
	git: 2.27.0 -> 2.28.0
	gnupg: 2.2.21 -> 2.2.23
	gnutls: 3.6.14 -> 3.6.15
	libffi: 3.3 -> 3.3_1
	libgpg-error: 1.38 -> 1.39
	mercurial: 5.1.2 -> 5.5_1
	p11-kit: 0.23.20_1 -> 0.23.21
	p5-Mozilla-CA: 20180117 -> 20200520
	perl5: 5.30.3 -> 5.32.0
	python37: 3.7.8_1 -> 3.7.9
	sqlite3: 3.32.3,1 -> 3.33.0,1
	sudo: 1.9.1 -> 1.9.3
	trousers: 0.3.14_2 -> 0.3.14_3

Installed packages to be REINSTALLED:
	p5-Authen-SASL-2.16_1 (direct dependency changed: perl5)
	p5-CGI-4.50 (direct dependency changed: perl5)
	p5-Digest-HMAC-1.03_1 (direct dependency changed: perl5)
	p5-Error-0.17029 (direct dependency changed: perl5)
	p5-GSSAPI-0.28_1 (direct dependency changed: perl5)
	p5-HTML-Parser-3.72 (direct dependency changed: perl5)
	p5-HTML-Tagset-3.20_1 (direct dependency changed: perl5)
	p5-IO-Socket-INET6-2.72_1 (direct dependency changed: perl5)
	p5-IO-Socket-SSL-2.068 (direct dependency changed: perl5)
	p5-Net-SSLeay-1.88 (direct dependency changed: perl5)
	p5-Socket6-0.29 (direct dependency changed: perl5)
	p5-Term-ReadKey-2.38_1 (direct dependency changed: perl5)
	p5-subversion-1.14.0 (direct dependency changed: perl5)

Number of packages to be installed: 6
Number of packages to be upgraded: 17
Number of packages to be reinstalled: 13

The process will require 35 MiB more space.
59 MiB to be downloaded.
[1/36] Fetching trousers-0.3.14_3.txz: .......... done
[2/36] Fetching sudo-1.9.3.txz: .......... done
[3/36] Fetching sqlite3-3.33.0,1.txz: .......... done
[4/36] Fetching python37-3.7.9.txz: .......... done
[5/36] Fetching perl5-5.32.0.txz: .......... done
[6/36] Fetching p5-subversion-1.14.0.txz: .......... done
[7/36] Fetching p5-Term-ReadKey-2.38_1.txz: ... done
[8/36] Fetching p5-Socket6-0.29.txz: ... done
[9/36] Fetching p5-Net-SSLeay-1.88.txz: .......... done
[10/36] Fetching p5-Mozilla-CA-20200520.txz: .......... done
[11/36] Fetching p5-IO-Socket-SSL-2.068.txz: .......... done
[12/36] Fetching p5-IO-Socket-INET6-2.72_1.txz: .. done
[13/36] Fetching p5-HTML-Tagset-3.20_1.txz: .. done
[14/36] Fetching p5-HTML-Parser-3.72.txz: .......... done
[15/36] Fetching p5-GSSAPI-0.28_1.txz: ...... done
[16/36] Fetching p5-Error-0.17029.txz: .... done
[17/36] Fetching p5-Digest-HMAC-1.03_1.txz: .. done
[18/36] Fetching p5-CGI-4.50.txz: .......... done
[19/36] Fetching p5-Authen-SASL-2.16_1.txz: ...... done
[20/36] Fetching p11-kit-0.23.21.txz: .......... done
[21/36] Fetching mercurial-5.5_1.txz: .......... done
[22/36] Fetching libgpg-error-1.39.txz: .......... done
[23/36] Fetching libffi-3.3_1.txz: ..... done
[24/36] Fetching gnutls-3.6.15.txz: .......... done
[25/36] Fetching gnupg-2.2.23.txz: .......... done
[26/36] Fetching git-2.28.0.txz: .......... done
[27/36] Fetching gettext-runtime-0.21.txz: .......... done
[28/36] Fetching curl-7.72.0.txz: .......... done
[29/36] Fetching ca_root_nss-3.57.txz: .......... done
[30/36] Fetching bash-5.0.18_3.txz: .......... done
[31/36] Fetching libedit-3.1.20191231,1.txz: .......... done
[32/36] Fetching bash-completion-2.11,2.txz: .......... done
[33/36] Fetching glib-2.66.0_1,1.txz: .......... done
[34/36] Fetching libxml2-2.9.10.txz: .......... done
[35/36] Fetching libiconv-1.16.txz: .......... done
[36/36] Fetching py37-setuptools-44.0.0.txz: .......... done
Checking integrity... done (0 conflicting)
[1/36] Upgrading libffi from 3.3 to 3.3_1...
[1/36] Extracting libffi-3.3_1: .......... done
[2/36] Upgrading gettext-runtime from 0.20.2 to 0.21...
[2/36] Extracting gettext-runtime-0.21: .......... done
[3/36] Upgrading python37 from 3.7.8_1 to 3.7.9...
[3/36] Extracting python37-3.7.9: .......... done
[4/36] Upgrading libgpg-error from 1.38 to 1.39...
[4/36] Extracting libgpg-error-1.39: .......... done
[5/36] Upgrading bash from 5.0.17 to 5.0.18_3...
[5/36] Extracting bash-5.0.18_3: .......... done
[6/36] Installing libxml2-2.9.10...
[6/36] Extracting libxml2-2.9.10: .......... done
[7/36] Installing libiconv-1.16...
[7/36] Extracting libiconv-1.16: .......... done
[8/36] Upgrading ca_root_nss from 3.54 to 3.57...
[8/36] Extracting ca_root_nss-3.57: ........ done
[9/36] Installing bash-completion-2.11,2...
[9/36] Extracting bash-completion-2.11,2: .......... done
[10/36] Installing glib-2.66.0_1,1...
[10/36] Extracting glib-2.66.0_1,1: .......... done
No schema files found: doing nothing.
[11/36] Upgrading trousers from 0.3.14_2 to 0.3.14_3...
===> Creating groups.
Using existing group '_tss'.
===> Creating users
Using existing user '_tss'.
[11/36] Extracting trousers-0.3.14_3: .......... done
[12/36] Upgrading p11-kit from 0.23.20_1 to 0.23.21...
[12/36] Extracting p11-kit-0.23.21: .......... done
[13/36] Installing libedit-3.1.20191231,1...
[13/36] Extracting libedit-3.1.20191231,1: .......... done
[14/36] Upgrading sqlite3 from 3.32.3,1 to 3.33.0,1...
[14/36] Extracting sqlite3-3.33.0,1: .......... done
[15/36] Upgrading perl5 from 5.30.3 to 5.32.0...
[15/36] Extracting perl5-5.32.0: .......... done
[16/36] Upgrading gnutls from 3.6.14 to 3.6.15...
[16/36] Extracting gnutls-3.6.15: .......... done
[17/36] Reinstalling p5-Socket6-0.29...
[17/36] Extracting p5-Socket6-0.29: ....... done
[18/36] Reinstalling p5-HTML-Tagset-3.20_1...
[18/36] Extracting p5-HTML-Tagset-3.20_1: ....... done
[19/36] Upgrading gnupg from 2.2.21 to 2.2.23...
[19/36] Extracting gnupg-2.2.23: .......... done
[20/36] Reinstalling p5-Net-SSLeay-1.88...
[20/36] Extracting p5-Net-SSLeay-1.88: .......... done
[21/36] Upgrading p5-Mozilla-CA from 20180117 to 20200520...
[21/36] Extracting p5-Mozilla-CA-20200520: ........ done
[22/36] Reinstalling p5-IO-Socket-INET6-2.72_1...
[22/36] Extracting p5-IO-Socket-INET6-2.72_1: ....... done
[23/36] Reinstalling p5-HTML-Parser-3.72...
[23/36] Extracting p5-HTML-Parser-3.72: .......... done
[24/36] Reinstalling p5-GSSAPI-0.28_1...
[24/36] Extracting p5-GSSAPI-0.28_1: .......... done
[25/36] Reinstalling p5-Digest-HMAC-1.03_1...
[25/36] Extracting p5-Digest-HMAC-1.03_1: .......... done
[26/36] Reinstalling p5-subversion-1.14.0...
[26/36] Extracting p5-subversion-1.14.0: .......... done
[27/36] Reinstalling p5-Term-ReadKey-2.38_1...
[27/36] Extracting p5-Term-ReadKey-2.38_1: ........ done
[28/36] Reinstalling p5-IO-Socket-SSL-2.068...
[28/36] Extracting p5-IO-Socket-SSL-2.068: .......... done
[29/36] Reinstalling p5-Error-0.17029...
[29/36] Extracting p5-Error-0.17029: ......... done
[30/36] Reinstalling p5-CGI-4.50...
[30/36] Extracting p5-CGI-4.50: .......... done
[31/36] Reinstalling p5-Authen-SASL-2.16_1...
[31/36] Extracting p5-Authen-SASL-2.16_1: .......... done
[32/36] Upgrading curl from 7.71.1 to 7.72.0...
[32/36] Extracting curl-7.72.0: .......... done
[33/36] Installing py37-setuptools-44.0.0...
[33/36] Extracting py37-setuptools-44.0.0: .......... done
[34/36] Upgrading sudo from 1.9.1 to 1.9.3...
[34/36] Extracting sudo-1.9.3: .......... done
You may need to manually remove /usr/local/etc/sudoers if it is no longer needed.
[35/36] Upgrading mercurial from 5.1.2 to 5.5_1...
[35/36] Extracting mercurial-5.5_1: .......... done
[36/36] Upgrading git from 2.27.0 to 2.28.0...
===> Creating groups.
Using existing group 'git_daemon'.
===> Creating users
Using existing user 'git_daemon'.
[36/36] Extracting git-2.28.0: .......... done
=====
Message from bash-completion-2.11,2:

--
To enable the bash completion library, add the following to
your .bashrc file:

[[ $PS1 && -f /usr/local/share/bash-completion/bash_completion.sh ]] && \
	source /usr/local/share/bash-completion/bash_completion.sh

See /usr/local/share/doc/bash-completion/README.md for more information.
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 4 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
	arm-none-eabi-binutils: 2.33.1_3,1
	arm-none-eabi-gcc: 8.4.0_2
	mpc: 1.1.0_2
	mpfr: 4.1.0

Number of packages to be installed: 4

The process will require 148 MiB more space.
23 MiB to be downloaded.
[1/4] Fetching arm-none-eabi-gcc-8.4.0_2.txz: .......... done
[2/4] Fetching mpfr-4.1.0.txz: .......... done
[3/4] Fetching mpc-1.1.0_2.txz: .......... done
[4/4] Fetching arm-none-eabi-binutils-2.33.1_3,1.txz: .......... done
Checking integrity... done (0 conflicting)
[1/4] Installing mpfr-4.1.0...
[1/4] Extracting mpfr-4.1.0: .......... done
[2/4] Installing mpc-1.1.0_2...
[2/4] Extracting mpc-1.1.0_2: ......... done
[3/4] Installing arm-none-eabi-binutils-2.33.1_3,1...
[3/4] Extracting arm-none-eabi-binutils-2.33.1_3,1: .......... done
[4/4] Installing arm-none-eabi-gcc-8.4.0_2...
[4/4] Extracting arm-none-eabi-gcc-8.4.0_2: .......... done
=====
Message from arm-none-eabi-binutils-2.33.1_3,1:

--
===>   NOTICE:

The arm-none-eabi-binutils port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
[#311310] 2020/09/29 21:33:53 Cloning repositories
Cloning into 'salty'...
+ cd salty
+ git checkout -q fb96309369e7c23135a6545f023f87aff3b538b1
+ cd salty
+ git submodule update --init
[#311310] 2020/09/29 21:33:54 Running task setup
[#311310] 2020/09/29 21:34:12 Running task build-tweetnacl
[#311310] 2020/09/29 21:34:29 Processing post-failed triggers...
[#311310] 2020/09/29 21:34:30 Sending webhook...
[#311310] 2020/09/29 21:34:30 Webhook response: 200
[#311310] 2020/09/29 21:34:30 Error updating GitHub status
[#311310] 2020/09/29 21:34:30 Build failed.
[#311310] 2020/09/29 21:34:30 The build environment will be kept alive for 10 minutes.
[#311310] 2020/09/29 21:34:30 To log in with SSH and examine it, use the following command:
[#311310] 2020/09/29 21:34:30 
[#311310] 2020/09/29 21:34:30 	ssh -t builds@azusa.runners.sr.ht connect 311310
[#311310] 2020/09/29 21:34:30 
[#311310] 2020/09/29 21:34:30 After logging in, the deadline is increased to your remaining build time.
[#311310] 2020/09/29 21:44:30 Deadline elapsed. Terminating build environment.
[#311310] 2020/09/29 21:44:30 Error: Running task on guest: exit status 101
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
+ curl -sSf https://sh.rustup.rs
+ sh -s -- -y -q
info: downloading installer
info: profile set to 'default'
info: default host triple is x86_64-unknown-freebsd
info: syncing channel updates for 'stable-x86_64-unknown-freebsd'
info: latest update on 2020-08-27, rust version 1.46.0 (04488afe3 2020-08-24)
info: downloading component 'cargo'
info: downloading component 'clippy'
info: downloading component 'rust-std'
info: downloading component 'rustc'
info: downloading component 'rustfmt'
info: installing component 'cargo'
info: Defaulting to 500.0 MiB unpack ram
info: installing component 'clippy'
info: installing component 'rust-std'
info: installing component 'rustc'
info: installing component 'rustfmt'
info: default toolchain set to 'stable'

  stable installed - rustc 1.46.0 (04488afe3 2020-08-24)


Rust is installed now. Great!

To get started you need Cargo's bin directory ($HOME/.cargo/bin) in your PATH
environment variable. Next time you log in this will be done
automatically.

To configure your current shell run source $HOME/.cargo/env
+ source /home/build/.cargo/env
++ export PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
++ PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
+ rustup target add thumbv7em-none-eabi
info: downloading component 'rust-std' for 'thumbv7em-none-eabi'
info: installing component 'rust-std' for 'thumbv7em-none-eabi'
info: Defaulting to 500.0 MiB unpack ram
build-tweetnacl
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
+ cd salty
+ source /home/build/.cargo/env
++ export PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
++ PATH=/home/build/.cargo/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/build/bin
+ RUSTFLAGS='-D warnings'
+ cargo build --release --features tweetnacl-on-cortex-m4 --target thumbv7em-none-eabi
    Updating crates.io index
 Downloading crates ...
  Downloaded subtle v2.3.0
   Compiling salty v0.1.0-alpha.1 (/usr/home/build/salty)
   Compiling subtle v2.3.0
error: associated function is never used: `montgomery_square`
   --> src/scalar29.rs:392:12
    |
392 |     pub fn montgomery_square(&self) -> Scalar29 {
    |            ^^^^^^^^^^^^^^^^^
    |
    = note: `-D dead-code` implied by `-D warnings`

error: associated function is never used: `to_montgomery`
   --> src/scalar29.rs:398:12
    |
398 |     pub fn to_montgomery(&self) -> Scalar29 {
    |            ^^^^^^^^^^^^^

error: associated function is never used: `from_montgomery`
   --> src/scalar29.rs:403:12
    |
403 |     pub fn from_montgomery(&self) -> Scalar29 {
    |            ^^^^^^^^^^^^^^^

error: aborting due to 3 previous errors

error: could not compile `salty`.

To learn more, run the command again with --verbose.
Build complete: failed 3 months ago (took a minute)