#83991 success

resume readthedocs

bbb1647Nhan

Owner
~nhanb
Created
1 year, 7 months ago
Updated
1 year, 7 months ago
Build manifest
view manifest »

Tasks

view log »
setup view log »
test view log »
check-publish view log »
publish view log »
go to bottom »
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
[#83991] 2019/08/24 16:55:28 Booting image archlinux (default) on port 22084
[#83991] 2019/08/24 16:55:31 Waiting for guest to settle
[#83991] 2019/08/24 16:55:38 Sending tasks
[#83991] 2019/08/24 16:55:39 Sending build environment
[#83991] 2019/08/24 16:55:39 Sending secrets
[#83991] 2019/08/24 16:55:39 Resolving secret b460cca6-77a9-4041-b928-b781b3b3f6ab
[#83991] 2019/08/24 16:55:39 Installing packages
Warning: Permanently added '[localhost]:22084' (ECDSA) to the list of known hosts.
:: Synchronizing package databases...
downloading core.db...
downloading extra.db...
downloading community.db...
:: Starting full system upgrade...
warning: linux: ignoring package upgrade (5.2.8.arch1-1 => 5.2.9.arch1-1)
warning: linux-firmware: ignoring package upgrade (20190717.bf13a71-1 => 20190815.07b925b-1)
resolving dependencies...
looking for conflicting packages...

Packages (21) cryptsetup-2.2.0-1  dbus-1.12.16-2  gettext-0.20.1-1  git-2.23.0-1  libnghttp2-1.39.2-1  man-db-2.8.6.1-1  man-pages-5.02-1  mercurial-5.1-1  pacman-mirrorlist-20190821-1  perl-error-0.17028-1  python-3.7.4-1  python-appdirs-1.4.3-2  python-attrs-19.1.0-1  python-packaging-19.1-2  python-pyparsing-2.4.2-1  python-six-1.12.0-1  systemd-242.84-2  systemd-libs-242.84-2  systemd-sysvcompat-242.84-2  poetry-0.12.17-1  python-setuptools-1:41.2.0-1

Total Download Size:    61.76 MiB
Total Installed Size:  273.70 MiB
Net Upgrade Size:      166.24 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading systemd-libs-242.84-2-x86_64.pkg.tar.xz...
downloading cryptsetup-2.2.0-1-x86_64.pkg.tar.xz...
downloading dbus-1.12.16-2-x86_64.pkg.tar.xz...
downloading gettext-0.20.1-1-x86_64.pkg.tar.xz...
downloading libnghttp2-1.39.2-1-x86_64.pkg.tar.xz...
downloading systemd-242.84-2-x86_64.pkg.tar.xz...
downloading man-db-2.8.6.1-1-x86_64.pkg.tar.xz...
downloading man-pages-5.02-1-any.pkg.tar.xz...
downloading pacman-mirrorlist-20190821-1-any.pkg.tar.xz...
downloading systemd-sysvcompat-242.84-2-x86_64.pkg.tar.xz...
downloading python-3.7.4-1-x86_64.pkg.tar.xz...
downloading python-appdirs-1.4.3-2-any.pkg.tar.xz...
downloading python-attrs-19.1.0-1-any.pkg.tar.xz...
downloading python-pyparsing-2.4.2-1-any.pkg.tar.xz...
downloading python-six-1.12.0-1-any.pkg.tar.xz...
downloading python-packaging-19.1-2-any.pkg.tar.xz...
downloading python-setuptools-1:41.2.0-1-any.pkg.tar.xz...
downloading perl-error-0.17028-1-any.pkg.tar.xz...
downloading git-2.23.0-1-x86_64.pkg.tar.xz...
downloading mercurial-5.1-1-x86_64.pkg.tar.xz...
downloading poetry-0.12.17-1-any.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
installing python...
Optional dependencies for python
    python-setuptools [pending]
    python-pip
    sqlite [installed]
    mpdecimal: for decimal
    xz: for lzma [installed]
    tk: for tkinter
installing python-appdirs...
installing python-attrs...
installing python-pyparsing...
installing python-six...
installing python-packaging...
installing python-setuptools...
installing poetry...
upgrading systemd-libs...
upgrading cryptsetup...
upgrading dbus...
upgrading gettext...
upgrading perl-error...
upgrading libnghttp2...
upgrading systemd...
upgrading git...
upgrading man-db...
upgrading man-pages...
upgrading mercurial...
upgrading pacman-mirrorlist...
upgrading systemd-sysvcompat...
warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
:: Running post-transaction hooks...
( 1/12) Creating system user accounts...
( 2/12) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.2.8-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.2.8-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
( 3/12) Reloading system bus configuration...
( 4/12) Warn about old perl modules
( 5/12) Updating journal message catalog...
( 6/12) Reloading system manager configuration...
( 7/12) Updating udev hardware database...
( 8/12) Applying kernel sysctl settings...
( 9/12) Creating temporary files...
(10/12) Reloading device manager configuration...
(11/12) Arming ConditionNeedsUpdate...
(12/12) Updating the info directory file...
:: Searching databases for updates...
:: Searching AUR for updates...
 -> linux: ignoring package upgrade (5.2.8.arch1-1 => 5.2.9.arch1-1)
 -> linux-firmware: ignoring package upgrade (20190717.bf13a71-1 => 20190815.07b925b-1)
 there is nothing to do
[#83991] 2019/08/24 16:57:12 Cloning repositories
Cloning into 'fundoshi'...
+ cd fundoshi
+ git submodule update --init
[#83991] 2019/08/24 16:57:13 Running task setup
[#83991] 2019/08/24 16:58:22 Running task test
[#83991] 2019/08/24 16:58:30 Running task check-publish
[#83991] 2019/08/24 16:58:31 Processing post-success triggers...
[#83991] 2019/08/24 16:58:31 Sending webhook...
[#83991] 2019/08/24 16:58:31 Webhook response: 200
[#83991] 2019/08/24 16:58:31 Sent build status to GitHub
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
+ cd fundoshi
+ poetry install
Creating virtualenv fundoshi-py3.7 in /home/build/.cache/pypoetry/virtualenvs
Installing dependencies from lock file


Package operations: 72 installs, 0 updates, 0 removals

  - Installing attrs (19.1.0)
  - Installing certifi (2019.6.16)
  - Installing chardet (3.0.4)
  - Installing decorator (4.4.0)
  - Installing idna (2.8)
  - Installing ipython-genutils (0.2.0)
  - Installing markupsafe (1.1.1)
  - Installing multidict (4.5.2)
  - Installing parso (0.5.1)
  - Installing ptyprocess (0.6.0)
  - Installing pyparsing (2.4.2)
  - Installing pytz (2019.2)
  - Installing six (1.12.0)
  - Installing urllib3 (1.25.3)
  - Installing wcwidth (0.1.7)
  - Installing zipp (0.5.2)
  - Installing alabaster (0.7.12)
  - Installing argh (0.26.2)
  - Installing babel (2.7.0)
  - Installing backcall (0.1.0)
  - Installing docutils (0.15.2)
  - Installing future (0.17.1)
  - Installing imagesize (1.1.0)
  - Installing importlib-metadata (0.19)
  - Installing jedi (0.14.1)
  - Installing jinja2 (2.10.1)
  - Installing packaging (19.1)
  - Installing pathtools (0.1.2)
  - Installing pexpect (4.7.0)
  - Installing pickleshare (0.7.5)
  - Installing prompt-toolkit (2.0.9)
  - Installing pygments (2.4.2)
  - Installing pyyaml (5.1.2)
  - Installing requests (2.22.0)
  - Installing snowballstemmer (1.9.0)
  - Installing sphinxcontrib-applehelp (1.0.1)
  - Installing sphinxcontrib-devhelp (1.0.1)
  - Installing sphinxcontrib-htmlhelp (1.0.2)
  - Installing sphinxcontrib-jsmath (1.0.1)
  - Installing sphinxcontrib-qthelp (1.0.2)
  - Installing sphinxcontrib-serializinghtml (1.1.3)
  - Installing tornado (6.0.3)
  - Installing traitlets (4.3.2)
  - Installing wrapt (1.11.2)
  - Installing yarl (1.3.0)
  - Installing appdirs (1.4.3)
  - Installing click (7.0)
  - Installing entrypoints (0.3)
  - Installing ipython (7.7.0)
  - Installing livereload (2.6.1)
  - Installing mccabe (0.6.1)
  - Installing pluggy (0.12.0)
  - Installing port-for (0.3.1)
  - Installing pycodestyle (2.5.0)
  - Installing pyflakes (2.1.1)
  - Installing python-jsonrpc-server (0.2.0)
  - Installing soupsieve (1.9.3)
  - Installing sphinx (2.2.0)
  - Installing toml (0.10.0)
  - Installing vcrpy (2.1.0)
  - Installing watchdog (0.9.0)
  - Installing beautifulsoup4 (4.8.0)
  - Installing black (18.9b0)
  - Installing flake8 (3.7.8)
  - Installing ipdb (0.12.2)
  - Installing isort (4.3.21)
  - Installing lxml (4.4.1)
  - Installing nose (1.3.7)
  - Installing python-language-server (0.28.1)
  - Installing sphinx-autobuild (0.7.1)
  - Installing sphinx-rtd-theme (0.4.3)
  - Installing vcrpy-unittest (0.1.7)
  - Installing fundoshi (0.1.0-alpha.0)
test
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
+ cd fundoshi
+ make test
poetry run flake8
poetry run black --check **/*.py
All done! ✨ 🍰 ✨
5 files would be left unchanged.
poetry run isort --check-only
Skipped 1 files
cd docs && make doctest
make[1]: Entering directory '/home/build/fundoshi/docs'
poetry run sphinx-build -b doctest -d _build/doctrees   . _build/doctest
Running Sphinx v2.2.0
making output directory... done
building [mo]: targets for 0 po files that are out of date
building [doctest]: targets for 4 source files that are out of date
updating environment: [new config] 4 added, 0 changed, 0 removed
reading sources... [ 25%] dev
reading sources... [ 50%] faq
reading sources... [ 75%] index
reading sources... [100%] usage

looking for now-outdated files... none found
pickling environment... done
checking consistency... done
running tests...

Document: usage
---------------
1 items passed all tests:
  10 tests in default
10 tests in 1 items.
10 passed and 0 failed.
Test passed.
1 items passed all tests:
   1 tests in default (cleanup code)
1 tests in 1 items.
1 passed and 0 failed.
Test passed.

Doctest summary
===============
   10 tests
    0 failures in tests
    0 failures in setup code
    0 failures in cleanup code
build succeeded.

Testing of doctests in the sources finished, look at the results in _build/doctest/output.txt.
Testing of doctests in the sources finished, look at the  results in _build/doctest/output.txt.
make[1]: Leaving directory '/home/build/fundoshi/docs'
poetry run python -m unittest
Using VCRTestCase as base test class.
......
----------------------------------------------------------------------
Ran 6 tests in 0.536s

OK
check-publish
1
2
3
4
5
6
+ [[ push == \p\u\s\h ]]
+ [[ refs/heads/master =~ ^refs/tags/ ]]
+ echo 'Not deploying.'
Not deploying.
+ complete-build
+ exit 255
publish
Error fetching logs for task "publish"
Build complete: success 1 year, 7 months ago (took 3 minutes)