#278609 failed

Resubmission of build #278605

Owner
~michalr
Created
1 year, 2 months ago
Updated
1 year, 2 months ago
Build manifest
view manifest »

Tasks

view log »
install-deps view log »
compile view log »
test view log »
go to bottom »
go to top »
setup
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
[#278609] 2020/08/12 21:20:25 Booting image debian/stable (default) on port 22194
[#278609] 2020/08/12 21:20:25 Waiting for guest to settle
[#278609] 2020/08/12 21:20:33 Sending tasks
[#278609] 2020/08/12 21:20:33 Sending build environment
[#278609] 2020/08/12 21:20:33 Installing packages
Warning: Permanently added '[localhost]:22194' (ECDSA) to the list of known hosts.
Hit:1 http://deb.debian.org/debian buster InRelease
Reading package lists...
Warning: Permanently added '[localhost]:22194' (ECDSA) to the list of known hosts.
Reading package lists...
Building dependency tree...
Reading state information...
gnupg is already the newest version (2.2.12-1+deb10u1).
The following additional packages will be installed:
  binfmt-support clang-7 lib32gcc1 lib32stdc++6 libc6-i386
  libclang-common-7-dev libclang1-7 libcurl4 libffi-dev libgc1c2 libllvm7
  liblzma-dev libncurses-dev libobjc-8-dev libobjc4 libomp-7-dev libomp5-7
  libpipeline1 libre2-5 libtinfo-dev libunwind8 llvm-7 llvm-7-dev
  llvm-7-runtime
Suggested packages:
  clang-7-doc liblzma-doc ncurses-doc libomp-7-doc llvm-7-doc
The following NEW packages will be installed:
  binfmt-support clang clang-7 curl lib32gcc1 lib32stdc++6 libc6-i386
  libclang-common-7-dev libclang1-7 libcurl4 libffi-dev libgc-dev libgc1c2
  libllvm7 liblzma-dev libncurses-dev libobjc-8-dev libobjc4 libomp-7-dev
  libomp5-7 libpipeline1 libre2-5 libre2-dev libtinfo-dev libunwind-dev
  libunwind8 llvm-7 llvm-7-dev llvm-7-runtime
0 upgraded, 29 newly installed, 0 to remove and 0 not upgraded.
Need to get 63.0 MB of archives.
After this operation, 375 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian buster/main amd64 libpipeline1 amd64 1.5.1-2 [31.2 kB]
Get:2 http://deb.debian.org/debian buster/main amd64 binfmt-support amd64 2.2.0-2 [70.0 kB]
Get:3 http://deb.debian.org/debian buster/main amd64 libllvm7 amd64 1:7.0.1-8 [13.0 MB]
Get:4 http://deb.debian.org/debian buster/main amd64 libgc1c2 amd64 1:7.6.4-0.4 [224 kB]
Get:5 http://deb.debian.org/debian buster/main amd64 libobjc4 amd64 8.3.0-6 [50.3 kB]
Get:6 http://deb.debian.org/debian buster/main amd64 libobjc-8-dev amd64 8.3.0-6 [226 kB]
Get:7 http://deb.debian.org/debian buster/main amd64 libc6-i386 amd64 2.28-10 [2872 kB]
Get:8 http://deb.debian.org/debian buster/main amd64 lib32gcc1 amd64 1:8.3.0-6 [47.9 kB]
Get:9 http://deb.debian.org/debian buster/main amd64 lib32stdc++6 amd64 8.3.0-6 [407 kB]
Get:10 http://deb.debian.org/debian buster/main amd64 libclang-common-7-dev amd64 1:7.0.1-8 [3154 kB]
Get:11 http://deb.debian.org/debian buster/main amd64 libclang1-7 amd64 1:7.0.1-8 [5993 kB]
Get:12 http://deb.debian.org/debian buster/main amd64 clang-7 amd64 1:7.0.1-8 [7891 kB]
Get:13 http://deb.debian.org/debian buster/main amd64 clang amd64 1:7.0-47 [7468 B]
Get:14 http://deb.debian.org/debian buster/main amd64 libcurl4 amd64 7.64.0-4+deb10u1 [331 kB]
Get:15 http://deb.debian.org/debian buster/main amd64 curl amd64 7.64.0-4+deb10u1 [264 kB]
Get:16 http://deb.debian.org/debian buster/main amd64 libffi-dev amd64 3.2.1-9 [156 kB]
Get:17 http://deb.debian.org/debian buster/main amd64 libgc-dev amd64 1:7.6.4-0.4 [373 kB]
Get:18 http://deb.debian.org/debian buster/main amd64 liblzma-dev amd64 5.2.4-1 [210 kB]
Get:19 http://deb.debian.org/debian buster/main amd64 libncurses-dev amd64 6.1+20181013-2+deb10u2 [333 kB]
Get:20 http://deb.debian.org/debian buster/main amd64 libomp5-7 amd64 1:7.0.1-8 [319 kB]
Get:21 http://deb.debian.org/debian buster/main amd64 libomp-7-dev amd64 1:7.0.1-8 [57.6 kB]
Get:22 http://deb.debian.org/debian buster/main amd64 libre2-5 amd64 20190101+dfsg-2 [161 kB]
Get:23 http://deb.debian.org/debian buster/main amd64 libre2-dev amd64 20190101+dfsg-2 [221 kB]
Get:24 http://deb.debian.org/debian buster/main amd64 libtinfo-dev amd64 6.1+20181013-2+deb10u2 [940 B]
Get:25 http://deb.debian.org/debian buster/main amd64 libunwind8 amd64 1.2.1-10~deb10u1 [51.1 kB]
Get:26 http://deb.debian.org/debian buster/main amd64 libunwind-dev amd64 1.2.1-10~deb10u1 [463 kB]
Get:27 http://deb.debian.org/debian buster/main amd64 llvm-7-runtime amd64 1:7.0.1-8 [190 kB]
Get:28 http://deb.debian.org/debian buster/main amd64 llvm-7 amd64 1:7.0.1-8 [4553 kB]
Get:29 http://deb.debian.org/debian buster/main amd64 llvm-7-dev amd64 1:7.0.1-8 [21.3 MB]
Fetched 63.0 MB in 6s (10.1 MB/s)
Selecting previously unselected package libpipeline1:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 30084 files and directories currently installed.)
Preparing to unpack .../00-libpipeline1_1.5.1-2_amd64.deb ...
Unpacking libpipeline1:amd64 (1.5.1-2) ...
Selecting previously unselected package binfmt-support.
Preparing to unpack .../01-binfmt-support_2.2.0-2_amd64.deb ...
Unpacking binfmt-support (2.2.0-2) ...
Selecting previously unselected package libllvm7:amd64.
Preparing to unpack .../02-libllvm7_1%3a7.0.1-8_amd64.deb ...
Unpacking libllvm7:amd64 (1:7.0.1-8) ...
Selecting previously unselected package libgc1c2:amd64.
Preparing to unpack .../03-libgc1c2_1%3a7.6.4-0.4_amd64.deb ...
Unpacking libgc1c2:amd64 (1:7.6.4-0.4) ...
Selecting previously unselected package libobjc4:amd64.
Preparing to unpack .../04-libobjc4_8.3.0-6_amd64.deb ...
Unpacking libobjc4:amd64 (8.3.0-6) ...
Selecting previously unselected package libobjc-8-dev:amd64.
Preparing to unpack .../05-libobjc-8-dev_8.3.0-6_amd64.deb ...
Unpacking libobjc-8-dev:amd64 (8.3.0-6) ...
Selecting previously unselected package libc6-i386.
Preparing to unpack .../06-libc6-i386_2.28-10_amd64.deb ...
Unpacking libc6-i386 (2.28-10) ...
Selecting previously unselected package lib32gcc1.
Preparing to unpack .../07-lib32gcc1_1%3a8.3.0-6_amd64.deb ...
Unpacking lib32gcc1 (1:8.3.0-6) ...
Selecting previously unselected package lib32stdc++6.
Preparing to unpack .../08-lib32stdc++6_8.3.0-6_amd64.deb ...
Unpacking lib32stdc++6 (8.3.0-6) ...
Selecting previously unselected package libclang-common-7-dev.
Preparing to unpack .../09-libclang-common-7-dev_1%3a7.0.1-8_amd64.deb ...
Unpacking libclang-common-7-dev (1:7.0.1-8) ...
Selecting previously unselected package libclang1-7.
Preparing to unpack .../10-libclang1-7_1%3a7.0.1-8_amd64.deb ...
Unpacking libclang1-7 (1:7.0.1-8) ...
Selecting previously unselected package clang-7.
Preparing to unpack .../11-clang-7_1%3a7.0.1-8_amd64.deb ...
Unpacking clang-7 (1:7.0.1-8) ...
Selecting previously unselected package clang.
Preparing to unpack .../12-clang_1%3a7.0-47_amd64.deb ...
Unpacking clang (1:7.0-47) ...
Selecting previously unselected package libcurl4:amd64.
Preparing to unpack .../13-libcurl4_7.64.0-4+deb10u1_amd64.deb ...
Unpacking libcurl4:amd64 (7.64.0-4+deb10u1) ...
Selecting previously unselected package curl.
Preparing to unpack .../14-curl_7.64.0-4+deb10u1_amd64.deb ...
Unpacking curl (7.64.0-4+deb10u1) ...
Selecting previously unselected package libffi-dev:amd64.
Preparing to unpack .../15-libffi-dev_3.2.1-9_amd64.deb ...
Unpacking libffi-dev:amd64 (3.2.1-9) ...
Selecting previously unselected package libgc-dev:amd64.
Preparing to unpack .../16-libgc-dev_1%3a7.6.4-0.4_amd64.deb ...
Unpacking libgc-dev:amd64 (1:7.6.4-0.4) ...
Selecting previously unselected package liblzma-dev:amd64.
Preparing to unpack .../17-liblzma-dev_5.2.4-1_amd64.deb ...
Unpacking liblzma-dev:amd64 (5.2.4-1) ...
Selecting previously unselected package libncurses-dev:amd64.
Preparing to unpack .../18-libncurses-dev_6.1+20181013-2+deb10u2_amd64.deb ...
Unpacking libncurses-dev:amd64 (6.1+20181013-2+deb10u2) ...
Selecting previously unselected package libomp5-7:amd64.
Preparing to unpack .../19-libomp5-7_1%3a7.0.1-8_amd64.deb ...
Unpacking libomp5-7:amd64 (1:7.0.1-8) ...
Selecting previously unselected package libomp-7-dev.
Preparing to unpack .../20-libomp-7-dev_1%3a7.0.1-8_amd64.deb ...
Unpacking libomp-7-dev (1:7.0.1-8) ...
Selecting previously unselected package libre2-5:amd64.
Preparing to unpack .../21-libre2-5_20190101+dfsg-2_amd64.deb ...
Unpacking libre2-5:amd64 (20190101+dfsg-2) ...
Selecting previously unselected package libre2-dev:amd64.
Preparing to unpack .../22-libre2-dev_20190101+dfsg-2_amd64.deb ...
Unpacking libre2-dev:amd64 (20190101+dfsg-2) ...
Selecting previously unselected package libtinfo-dev:amd64.
Preparing to unpack .../23-libtinfo-dev_6.1+20181013-2+deb10u2_amd64.deb ...
Unpacking libtinfo-dev:amd64 (6.1+20181013-2+deb10u2) ...
Selecting previously unselected package libunwind8:amd64.
Preparing to unpack .../24-libunwind8_1.2.1-10~deb10u1_amd64.deb ...
Unpacking libunwind8:amd64 (1.2.1-10~deb10u1) ...
Selecting previously unselected package libunwind-dev:amd64.
Preparing to unpack .../25-libunwind-dev_1.2.1-10~deb10u1_amd64.deb ...
Unpacking libunwind-dev:amd64 (1.2.1-10~deb10u1) ...
Selecting previously unselected package llvm-7-runtime.
Preparing to unpack .../26-llvm-7-runtime_1%3a7.0.1-8_amd64.deb ...
Unpacking llvm-7-runtime (1:7.0.1-8) ...
Selecting previously unselected package llvm-7.
Preparing to unpack .../27-llvm-7_1%3a7.0.1-8_amd64.deb ...
Unpacking llvm-7 (1:7.0.1-8) ...
Selecting previously unselected package llvm-7-dev.
Preparing to unpack .../28-llvm-7-dev_1%3a7.0.1-8_amd64.deb ...
Unpacking llvm-7-dev (1:7.0.1-8) ...
Setting up libpipeline1:amd64 (1.5.1-2) ...
Setting up libncurses-dev:amd64 (6.1+20181013-2+deb10u2) ...
Setting up libgc1c2:amd64 (1:7.6.4-0.4) ...
Setting up libobjc4:amd64 (8.3.0-6) ...
Setting up libffi-dev:amd64 (3.2.1-9) ...
Setting up libunwind8:amd64 (1.2.1-10~deb10u1) ...
Setting up libobjc-8-dev:amd64 (8.3.0-6) ...
Setting up libomp5-7:amd64 (1:7.0.1-8) ...
Setting up binfmt-support (2.2.0-2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/binfmt-support.service → /lib/systemd/system/binfmt-support.service.
Setting up liblzma-dev:amd64 (5.2.4-1) ...
Setting up libc6-i386 (2.28-10) ...
Setting up libre2-5:amd64 (20190101+dfsg-2) ...
Setting up libcurl4:amd64 (7.64.0-4+deb10u1) ...
Setting up libllvm7:amd64 (1:7.0.1-8) ...
Setting up curl (7.64.0-4+deb10u1) ...
Setting up libclang1-7 (1:7.0.1-8) ...
Setting up libre2-dev:amd64 (20190101+dfsg-2) ...
Setting up libgc-dev:amd64 (1:7.6.4-0.4) ...
Setting up libtinfo-dev:amd64 (6.1+20181013-2+deb10u2) ...
Setting up libunwind-dev:amd64 (1.2.1-10~deb10u1) ...
Setting up llvm-7-runtime (1:7.0.1-8) ...
Setting up llvm-7 (1:7.0.1-8) ...
Setting up lib32gcc1 (1:8.3.0-6) ...
Setting up libomp-7-dev (1:7.0.1-8) ...
Setting up lib32stdc++6 (8.3.0-6) ...
Setting up libclang-common-7-dev (1:7.0.1-8) ...
Setting up clang-7 (1:7.0.1-8) ...
Setting up llvm-7-dev (1:7.0.1-8) ...
Setting up clang (1:7.0-47) ...
Processing triggers for systemd (241-7~deb10u4) ...
Processing triggers for libc-bin (2.28-10) ...
[#278609] 2020/08/12 21:20:51 Cloning repositories
Cloning into 'wojabot'...
+ cd wojabot
+ git checkout -q 3b12d5f447d17ed9a2570fca35b85ac972488baa
+ cd wojabot
+ git submodule update --init
[#278609] 2020/08/12 21:20:52 Running task install-deps
[#278609] 2020/08/12 21:20:52 Build failed.
[#278609] 2020/08/12 21:20:52 The build environment will be kept alive for 10 minutes.
[#278609] 2020/08/12 21:20:52 To log in with SSH and examine it, use the following command:
[#278609] 2020/08/12 21:20:52 
[#278609] 2020/08/12 21:20:52 	ssh -t builds@yui.runners.sr.ht connect 278609
[#278609] 2020/08/12 21:20:52 
[#278609] 2020/08/12 21:20:52 After logging in, the deadline is increased to your remaining build time.
[#278609] 2020/08/12 21:21:54 Build cancelled. Terminating build environment.
[#278609] 2020/08/12 21:21:54 Error: Running task on guest: exit status 1
install-deps
1
2
3
4
+ echo 'deb https://dl.bintray.com/sbt/debian /'
+ tee -a /etc/apt/sources.list.d/sbt.list
tee: /etc/apt/sources.list.d/sbt.list: Permission denied
deb https://dl.bintray.com/sbt/debian /
Build complete: failed 1 year, 2 months ago (took 27 seconds)